Remove dependancy on Windows Mobile 6 SDK

Sep 18, 2009 at 6:32 PM

Hi, I have a need for using some zip extraction code on CE devices.
the target devices run CE 4.2 and CE 5.0

So on my dev machine i do not have the Win Mo 6 sdk loaded. when i open the dotnetzip source project it complains about not finding the sdk and then refuses to load the Zip CF projects at all.

I will now have to see if i can use the cf projects with some editing or if they have a hard depend on WInMo 6.

recomend that you build only to CE 5 as that will support many more devices and developers who are not using Windows Mobile .

Coordinator
Sep 18, 2009 at 8:01 PM

You don't need the source to DotNetZip in order to use the library in an application.

Can you not simply take the Devkit download, which includes the DLLs, and use the DotNetZip  (CF) dll ?

 

Sep 18, 2009 at 8:19 PM
I am tring that right now, I will let you know how it works out.
I have 2 devices to support
casio IT-3000 - CE 4.2
and casio IT-3100 CE 5.0
I have seen other libraries or code that will not run on CE 4.2
I have also seen issues with some code that works on 5 but not on 4.2 for some things like wireless config.
so I am always on the lookout for things working on 4.2 untill i know that all my customers have moved to the newer casio IT-3100.
thanks,
Denny.
-------- Original Message --------
Subject: Re: Remove dependancy on Windows Mobile 6 SDK
[DotNetZip:69410]
From: Cheeso <notifications@codeplex.com>
Date: Fri, September 18, 2009 3:01 pm
To: [email removed]

From: Cheeso
You don't need the source to DotNetZip in order to use the library in an application.
Can you not simply take the Devkit download, which includes the DLLs, and use the DotNetZip (CF) dll ?
To add a post to this discussion, reply to this email (mailto:DotNetZip@discussions.codeplex.com?subject=[DotNetZip:69410])
To start a new discussion for this project, email DotNetZip@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com
Sep 24, 2009 at 9:54 PM

WORKS!  Yeay :-)

works on a casio it-3000 running ce.net 4.2 with net cf 3.5

and by the way running .net cf 3.5 on ce.net 4.2 is not an officially supported case on the msft side.

but we are phasing out the it-3000 units in favor of the it-3100 units as time goes by.

Coordinator
Sep 24, 2009 at 9:58 PM

glad to hear it's working.