Multiple files zip with no compression

Sep 11, 2009 at 1:00 PM

Hi,

First of all thank you for your wonderful library!

I've been noticing that when I try to zip files using your Alpha release 1.9 using multiple files output and the no compression , I get twice as much data.

Were you aware of this issue?

Thanks

Vince

 

 

 

Coordinator
Sep 11, 2009 at 2:23 PM

No, I am not aware of this issue.  What do you mean "twice as much data" ?

Sep 11, 2009 at 2:40 PM

I am currently developping an application to test your library's performance.

When I save a whole directory using multiple files (segment size=5MB), I get the following results:

Using Default compression, results looks nice and acceptable.

******************************
Starting Compression
******************************
Compression Type:Default
Time elapsed:00:00:54.795
Initial Folder Size: 73.933 MB
Final Archive Size: 41.689 MB
Gained: 32.244 MB
Compression ratio: 43.61%
******************************
Compression ended

******************************

When i'm using I just "package" them using the compression level "none", I get the following results:

******************************
Starting Compression
******************************
Compression Type:None
Time elapsed:00:00:19.202
Initial Folder Size: 73.933 MB
Final Archive Size: 144.298 MB
Gained: -70.365 MB
Compression ratio: -95.17%
******************************
Compression ended
******************************

I also double-checked the file outputs and it matches the data obtained.

 

 

 

Coordinator
Sep 11, 2009 at 3:28 PM

Well that seems like a problem!  Let me look into it.

 

Coordinator
Sep 11, 2009 at 3:29 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Sep 11, 2009 at 5:32 PM

I've reproduced the behavior you reported.

Coordinator
Sep 11, 2009 at 7:22 PM

The fix is available in v1.9.0.5. 

Sep 11, 2009 at 7:27 PM

Thanks for your time!

 

Really appreciated!

 

Sep 14, 2009 at 1:21 PM
Edited Sep 14, 2009 at 2:06 PM

After a few tests, I found out that even if you specify no compression using mutliples files archive, it compresses data anyways

******************************
Starting Compression
******************************
Compression Type:None
Time elapsed:00:01:20.140
Initial Size: 270.695 MB
Final Size: 50.569 MB
Gained: 230818946 MB
Compression ratio: 81.32%
******************************
Compression ended
******************************

EDIT: NVM, this was an issue on my side, works fine now