TypeLoadException in CF 3.5 when declaring ZipFile (version 1.8)

Aug 27, 2009 at 12:17 AM
Edited Aug 27, 2009 at 12:21 AM

I declare:

ZipFile zip;

and get:

The version of the assembly System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089 cannot be loaded by this version of the Microsoft .NET Compact Framework.

If I take out this line its fine. Any idea? I'm using version 1.8 on .NET Compact Framwork 3.5 with the Windows Mobile 6 Professional Emulator.

Thanks,

Serge

 

Aug 27, 2009 at 12:31 AM
Edited Aug 27, 2009 at 12:31 AM

I figured this one out. I wasn't using the Ionic.Zip.CF.dll, instead I was using the dll that came with the runtime version.

Coordinator
Aug 27, 2009 at 3:18 AM

The "runtime" zip download includes the CF DLL.

The runtime MSI does not.  Yet.  I've just upated it so that in the future, the Runtime MSI will include the CF dll.