Zlib.Portable 1.9.2

Jun 17, 2014 at 5:48 PM
I am trying to install Zlib.Portable 1.9.2 library in a windows phone 8.1 project (non Silverlight) via nuget and getting the below error. Can you please release an updated nugget package that targets windows phone 8.1 as well? A number of libraries that I use are dependent on zlib (like google apis) and hence this is becoming a roadblock for me to upgrade my app to Windows Phone 8.1.

Error:

Install-Package : Could not install package 'Zlib.Portable 1.9.2'. You are trying to install this package into a project that targets
'WindowsPhoneApp,Version=v8.1', but the package does not contain any assembly references or content files that are compatible with that framework. For more
information, contact the package author.
At line:1 char:1
  • Install-Package Zlib.Portable
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
Jun 29, 2014 at 12:48 PM
I am getting the same error trying to install the Google.api.core:

Attempting to resolve dependency 'Newtonsoft.Json (≥ 5.0.5)'.
Attempting to resolve dependency 'Microsoft.Bcl (≥ 1.0.19)'.
Attempting to resolve dependency 'Microsoft.Bcl.Build (≥ 1.0.14)'.
Attempting to resolve dependency 'Microsoft.Bcl.Async (≥ 1.0.16)'.
Attempting to resolve dependency 'Microsoft.Net.Http (≥ 2.1.10)'.
Attempting to resolve dependency 'Zlib.Portable (≥ 1.9.2)'.
Installing 'Zlib.Portable 1.9.2'.
Successfully installed 'Zlib.Portable 1.9.2'.
Installing 'Google.Apis.Core 1.8.2'.
Successfully installed 'Google.Apis.Core 1.8.2'.
Adding 'Zlib.Portable 1.9.2' to GPhone.
Uninstalling 'Zlib.Portable 1.9.2'.
Successfully uninstalled 'Zlib.Portable 1.9.2'.
Install failed. Rolling back...
Could not install package 'Zlib.Portable 1.9.2'. You are trying to install this package into a project that targets 'WindowsPhoneApp,Version=v8.1', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.


Zlib by itself:

Installing 'Zlib.Portable 1.9.2'.
Successfully installed 'Zlib.Portable 1.9.2'.
Adding 'Zlib.Portable 1.9.2' to GPhone.
Uninstalling 'Zlib.Portable 1.9.2'.
Successfully uninstalled 'Zlib.Portable 1.9.2'.
Install failed. Rolling back...
Could not install package 'Zlib.Portable 1.9.2'. You are trying to install this package into a project that targets 'WindowsPhoneApp,Version=v8.1', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.